When you try to install a vagrant plugin and you get the following error:
vagrant plugin install vagrant-scp Installing the 'vagrant-vbguest' plugin. This can take a few minutes... Bundler, the underlying system Vagrant uses to install plugins, reported an error. The error is shown below. These errors are usually caused by misconfigured plugin installations or transient network issues. The error from Bundler is: conflicting dependencies fog-core (~> 1.43.0) and fog-core (= 1.45.0) Activated fog-core-1.45.0 which does not match conflicting dependency (~> 1.43.0) Conflicting dependency chains: fog-core (= 1.45.0), 1.45.0 activated versus: vagrant-libvirt (> 0), 0.0.41 activated, depends on fog-core (~> 1.43.0)
Download and install a newer version of vagrant. Check the version on the wget link!
wget -c https://releases.hashicorp.com/vagrant/2.0.3/vagrant_2.0.3_x86_64.deb sudo dpkg -i vagrant_2.0.3_x86_64.deb